Some Customers Experienced Testsigma Terminal Connection Issues Due to Configuration Problem

Incident Report for Testsigma Status

Postmortem

Incident Summary

On May 22nd, some customers faced issues with their local Testsigma Terminal connections. The incident was caused by a configuration problem that affected the terminal’s ability to establish or maintain connections correctly for a limited set of customers.

The issue was detected at around 4:30 AM UTC, and the engineering team immediately started investigating the problem. After identifying the configuration gap, the team applied the necessary fix and validated the terminal connectivity. The issue was fully resolved by approximately 6:00 AM UTC.

Impact

Only some customers using the local Testsigma Terminal experienced connection issues during the incident window. The issue did not impact all customers.

Incident window:
May 22nd, 4:30 AM UTC to 6:00 AM UTC

Affected component:
Testsigma Terminal connections

Customer impact:
A limited set of customers were unable to use terminal-based connectivity features during the affected period.

Root Cause

The incident was caused by a configuration problem that had previously gone unnoticed. This configuration issue impacted the ability of some local Testsigma Terminal instances to connect successfully.

Resolution

The team identified the configuration issue and applied the required fix. After the fix was implemented, the team validated the terminal connection flow and confirmed that the affected functionality was restored for the impacted customers.

Customers who were impacted may be required to update their local Testsigma Terminal to ensure they are using the latest corrected version.

Preventive Actions

To reduce the likelihood of similar incidents in the future, we are taking the following actions:

  1. Automating the management and validation of configuration-related changes.
  2. Improving internal checks to detect configuration issues earlier.
  3. Updating the local Testsigma Terminal to better handle configuration changes on customer machines.
  4. Strengthening release validation around terminal connectivity scenarios.

Current Status

The issue has been resolved, and terminal connectivity has been restored for the impacted customers. We will continue improving our configuration management and terminal handling mechanisms to prevent similar incidents in the future.

Posted May 25, 2026 - 03:57 UTC

Resolved

On May 22nd, some customers experienced issues connecting their local Testsigma Terminal to Testsigma due to a configuration-related problem.

The issue was identified by our team at approximately 4:30 AM UTC, after which we immediately began investigation and remediation. The root cause was traced to a configuration problem that had previously gone unnoticed and impacted terminal connectivity for a limited set of customers.

Our team fixed the configuration issue, validated the resolution, and confirmed that affected terminal connections were restored. The incident was resolved by approximately 6:00 AM UTC.

Customers who were impacted may need to update their local Testsigma Terminal to continue using terminal-based capabilities smoothly.

We apologize for the inconvenience caused to the affected customers and appreciate your patience while our team worked on resolving the issue.
Posted May 22, 2026 - 04:30 UTC